ArkhamK27

New Member
  • Content count

    2
  • Joined

  • Last visited

  1. Guys, when trying to patch, I get this message: "the specified executable is not a valid application for this operating system platform" Is it because I am using the special edition?