VincentASM

FE3 (Mystery of the Emblem) Translation Patch

46 posts in this topic

Current progress

Patch (zipped):

Fe3.zip

Missing:

  • Stats for the class scroll

Buggy:

  • Scrolling Intro (don't press anything for a while and you'll see it)
  • Various small graphical things.

Complete:

  • Everything else. :)

Fire Emblem 3 translation patch, I'm hacking, Vincent's translating, and Cleteromagos and AceNoctali provided some much-needed translations as well. Additional editing help provided by Devon_v and KiddoCabbusses. Nearly all the text is translated, and nearly everything that's translated is in the game.

New Patch (6/21, version 0.98):

New script revision! As always, credit goes to Vincent, who had help from Devon_v and KiddoCabbusses editing.

I knew I kept forgetting to do something. Anyway, if RPGuy96 comes here, I'll probably make them the topic creator instead.

Share this post


Link to post
Share on other sites

Oh goodie. Nice to have a new thread for it.

I want to ask - I tried the 1.1 patch version I used to test the translation itself on my ROM copier, but apparently on that the command menus and battle screens glitch up and scramble. Is this some real-hardware specific issue, or am I doing something wrong that the emulator doesn't note...?

Share this post


Link to post
Share on other sites
Oh goodie. Nice to have a new thread for it.

I want to ask - I tried the 1.1 patch version I used to test the translation itself on my ROM copier, but apparently on that the command menus and battle screens glitch up and scramble. Is this some real-hardware specific issue, or am I doing something wrong that the emulator doesn't note...?

It's probably the ROM file itself that's the problem; I remember this happened to me when I applied the translation patch to FE4. Try a different ROM file and see what happens.

Share this post


Link to post
Share on other sites

I guess I'll try it with the 1.0 patch, particularly since no one's ever been able to tell me what the differences were. Thanks for the tip, I'll see if it gives a good result.

(As for FE4, I can't get that to boot at all. The only one I got to play exactly as it does as if emulated is Thracia).

Share this post


Link to post
Share on other sites

Hmm. No luck. a Completely different ROM gives an identical result.

It must be something else.

Share this post


Link to post
Share on other sites
Hmm. No luck. a Completely different ROM gives an identical result.

It must be something else.

When I said ROM, I meant the file itself, not the patch.

What happened with me was this: I downloaded one version of the FE4 ROM and applied the translation to that, but the text got all garbled up. So then I downloaded a different ROM file and applied the same patch to it and it worked fine.

I'm not sure if you understood me properly there.

Share this post


Link to post
Share on other sites

That's exactly what I meant. -_-;

(EDIT: Also, blast it. After all my tries FE4 finally spew ed out it's Copy protection message. Aw, well.)

Edited by Kiddo

Share this post


Link to post
Share on other sites
That's exactly what I meant. -_-;

Oh, okay then. In that case, I'm not quite sure how to help. Sorry.

Share this post


Link to post
Share on other sites

Well, I've been trying to think of things that might help. I put in the original Japanese ROM and it works fine, so it's not like there's an inherent ROM copier incompatibility....

I'm honestly pondering if it's a problem with it running on real hardware. Who were the other folks who tested this on such and what was their setup? I got a Super UFO PRO 7 34M.

Share this post


Link to post
Share on other sites

SNESTool can add a header back on. There might be some other programs that can do the same.

Share this post


Link to post
Share on other sites

This is weird, but I have about 8 different releases of the FE3 ROM and this patch doesn't work with any of them in ZSNES or snesx9

in the rom file name the differences are stuff like (h1)(b1)(h2), etc... I assume the H stands for header, but it's not working with any of them.

Edited by Aozaki Touko

Share this post


Link to post
Share on other sites

I have no clue why you'd need eight different releases. I'm guessing there's times two for the two versions of the game, and another times two for the headers, as you mentioned. No clue what the other factor could be though.

The only thing I can really suggest is download the ROM from somewhere else. There shouldn't be a shortage of places that distribute SNES ROMs.

Share this post


Link to post
Share on other sites

I used snes tools and gave the rom a header then got it patched. The fucking thing freezes at the map right after the intro. The music keeps playing though.

Share this post


Link to post
Share on other sites

Did the game work fine after it had the header added and before it was patched?

If it does work fine, what filetype is your FE3 ROM? Eg. .SMC

Share this post


Link to post
Share on other sites

It's also missing the non-battle-animation levelup/item obtained/item broken notifier.

Share this post


Link to post
Share on other sites

I have a question. I'm not sure if it goes here, but if you have the time, can you help me a small bit?

I added the patch to my ROM of the game, and attempted to add a header to the ROM, but instead of starting the process, SNEStool just said "Wrong File Size!". I haven't a clue what to do.

Share this post


Link to post
Share on other sites

You should add/remove the header first, before applying the patch.

That said, I wouldn't think you'd get a "wrong file size" error by doing what you did. What file size is your ROM anyway (in bytes)?

Share this post


Link to post
Share on other sites

Oh, I see. Thank you.

Before adding the patch, my ROM is 131,072 bytes. After adding the patch, it's 12,856,320 bytes.

Share this post


Link to post
Share on other sites

Hmm, something's definitely not right there. Your ROM should be 3,146,240 bytes (3.00 MB) to begin with. After patching, it should become 4,194,816 bytes (4.00 MB).

Is your ROM file a .smc file? Also, can you play it OK without the translation patch?

Share this post


Link to post
Share on other sites

I just tested it - whether the ROM has been patched or not, it still comes up with an error screen. And yes, it was a .SMC file.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.