Jyosua

Forum Upgrade Details

Recommended Posts

Hey guys, as you can see, we've upgraded the forums. There were some issues during the upgrade, so you may see things like broken spoiler tags. I believe these can be fixed by simply editing the post in Source mode and resubmitting. Unfortunately, Invision Power thought it was a brilliant idea to get rid of the reprocess posts feature, so I can't fix all those automatically anymore.

Anyhow, the other thing that you will want to know is that you have to log in with your Display Name now. We will probably change this to e-mail later on and may also enable some other integrations.

Additionally, the skins did not carry over to the new site. May they rest in peace. I'll be adding new skins in the coming week or so.

Lastly, there is still more server upgrades and work that will be done. There may be issues that arise, so I ask that you bear with us through those. There also may be some slowness with the site while it recaches everything on the forums.

Share this post


Link to post
Share on other sites

Some minor (hopefully quick fix) items that might help people adjust faster:

  • Non-rounded avatars that are at least 100x100 (currently they are forced to 90x90)
  • Bring back signatures (currently gone altogether)
     

Share this post


Link to post
Share on other sites
8 hours ago, Jyosua said:

I believe these can be fixed by simply editing the post in Source mode and resubmitting.

The Source Mode is not accessible. No button for it, and no means to access Full Reply, if it is there. We can only use WYSIWYG as traditional users at this time.

Share this post


Link to post
Share on other sites

There's no method of performing Indents w/o Bullet/Numbered lists too, fwiw.

 

Share this post


Link to post
Share on other sites
19 minutes ago, Makaze said:

Some minor (hopefully quick fix) items that might help people adjust faster:

  • Non-rounded avatars that are at least 100x100 (currently they are forced to 90x90)
  • Bring back signatures (currently gone altogether)

     

I sincerely hope sigs return.  Have we heard word on if they will return once everything gets sorted out.

Share this post


Link to post
Share on other sites

All I ask is that I start getting notifications again whenever someone posts in a topic I'm following/have posted in. I'm not getting those anymore, and it's too confusing for me to manually follow them all, especially with my dyslexia.

Share this post


Link to post
Share on other sites

Does anyone else have the problem not being able to read the posts on the latest page of certain threads.

It'll be lead to the second latest page. However when I click on the latest page, the site is empty.

 

Share this post


Link to post
Share on other sites
15 minutes ago, Eleanor Hume said:

Does anyone else have the problem not being able to read the posts on the latest page of certain threads.

It'll be lead to the second latest page. However when I click on the latest page, the site is empty.

 

Yes. I can only see posts from a single page in a thread, when I try to go to another it's just a blank page. I have to get out of the thread, go to the list of topics, and find the specific page I want.

Also, I guess I'm getting email notifications? I can't do that either, it's just as confusing for me...

Share this post


Link to post
Share on other sites

All I'd like are sigs and for everything in general to be sized down a little. It's all so big that I'm scrolling an awful lot on just one page. It's a bit annoying.

Share this post


Link to post
Share on other sites

Nice job! It's really nice. Really. (a bit big though)

By "skins" you mean the "change theme" option ? Because I kind of miss the green color everywhere in interface, it was quite iconic of SF.

Edited by Brand_Of_The_Exalt

Share this post


Link to post
Share on other sites
1 minute ago, Brand_Of_The_Exalt said:

By "skins" you mean the "change theme" option ? Because I kind of miss the green interface, it was quite iconic of SF.

Yea, that's what "Themes" are here.

Share this post


Link to post
Share on other sites
On 17/01/2017 at 7:35 PM, Elieson said:

Yea, that's what "Themes" are here.

OH YEAH ! I wasn't sure if skin was referring to the theme or member badge.

Edited by Brand_Of_The_Exalt

Share this post


Link to post
Share on other sites

We just need to patiently wait until Jyosua plants all the trees back. Unfortunately we have to do it all by hand, since the upgrade destroyed them.

Plus all the other technical things that I can't even imagine XD

After that, the member badges should be making a return. Providing the code is mostly the same, which I'm hopeful it is, but you can never be too sure.

Share this post


Link to post
Share on other sites

What I want above all else are non-rounded avatars and the return of sigs. 

Share this post


Link to post
Share on other sites
2 hours ago, Fire Emblem Fan said:

All I ask is that I start getting notifications again whenever someone posts in a topic I'm following/have posted in. I'm not getting those anymore, and it's too confusing for me to manually follow them all, especially with my dyslexia.

Click your name in the top right, go to Account Settings > Notification Settings and see if any of the options there fix your issue. One of the settings is for notifying you when content you follow is updated, so unless it's bugged that sounds like what you're looking for.

Share this post


Link to post
Share on other sites

Spoilers broke for me, I can't seem to edit my profile/avatar, can't get to last posted... post by the star button next to the thread title... sometimes a page doesn't load unless you refresh. Forums are randomly slow too.

Share this post


Link to post
Share on other sites
3 minutes ago, Tangerine said:

Click your name in the top right, go to Account Settings > Notification Settings and see if any of the options there fix your issue. One of the settings is for notifying you when content you follow is updated, so unless it's bugged that sounds like what you're looking for.

I tried this, and still only get email notifications.

Share this post


Link to post
Share on other sites

Linking individual posts doesn't work, nor linking posts by page number.

Share this post


Link to post
Share on other sites

A lot of stuff breaks during a big update like this; just let us know what you notice and it'll be fixed.

Edit: @Makaze, yeah, sounds like something that may need to be fixed.

For the slowness some users are experiencing, we've added new security features that no doubt need tinkering with, it's possible that's the cause of some of it. We have about 600 users online currently, which wouldn't be giving our servers any trouble.

Share this post


Link to post
Share on other sites
3 hours ago, Makaze said:
  • Non-rounded avatars that are at least 100x100 (currently they are forced to 90x90)

I'll look into it a bit later.

3 hours ago, Makaze said:
  • Bring back signatures (currently gone altogether)

From what I've read, the data isn't actually gone, it's just being rebuilt. There are a bunch of background processes that are rebuilding the forum data at the moment. I will take a look later, though.

3 hours ago, Makaze said:

The Source Mode is not accessible. No button for it, and no means to access Full Reply, if it is there. We can only use WYSIWYG as traditional users at this time.

So here's a breakdown: Invision Power decided to remove the BB Code source editing feature from the WYSIWYG editor because it was buggy. There are no plans to implement one later. Moderators have access to HTML Source mode, so they have some limited ability to fix important posts, but unfortunately I cannot enable this for everyone because of security reasons. There is no Full Reply editor. The WYSIWYG editor is all you get, but it still does understand some BB Code. At some point, that might eventually be deprecated, too. I'm really sorry, but at the very least, the WYSIWYG editor is actually quite good.

3 hours ago, Elieson said:

There's no method of performing Indents w/o Bullet/Numbered lists too, fwiw.

There is, now.

5 minutes ago, Lord Raven said:

Linking individual posts doesn't work, nor linking posts by page number.

8 minutes ago, Makaze said:

I tried this, and still only get email notifications.

There is a bug where apparently some members cannot change their notification settings for people they follow. This is likely a bug and I will look into it later.

Share this post


Link to post
Share on other sites

No more Source Mode for posts? Ouch. After all the years I've spent writing all my posts using BB-Code manually, that's gonna take some getting used to.

Share this post


Link to post
Share on other sites
Just now, Scarlet said:

No more Source Mode for posts? Ouch. After all the years I've spent writing all my posts using BB-Code manually, that's gonna take some getting used to.

You can still write bb code manually.

Share this post


Link to post
Share on other sites
Just now, Scarlet said:

No more Source Mode for posts? Ouch. After all the years I've spent writing all my posts using BB-Code manually, that's gonna take some getting used to.

From what I understand, you can still use most BBCode and it'll show up properly after you submit. Some things may be different, though, like spoiler tags obviously. (I also type code out manually for the most part myself.(

Share this post


Link to post
Share on other sites
2 minutes ago, Lord Raven said:

You can still write bb code manually.

1 minute ago, Kirie said:

From what I understand, you can still use most BBCode and it'll show up properly after you submit. Some things may be different, though, like spoiler tags obviously. (I also type code out manually for the most part myself.(

Test

Oh, you're right. Don't mind me, then~

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.